Splunk Search

How to disable typeahead

sfmandmdev
Path Finder

How do you disable typeahead? We want this turned off for all users by default.

Tags (1)
1 Solution

southeringtonp
Motivator

Have you tried just editing the 'user' role and removing the capability?

In the Manager, go into Access Controls, choose Roles, and look under Selected Capabilities. You should see a capability called 'get_typeahead' -- remove it and Save.

Alternately, edit local/authorize.conf and add:

[role_user]
get_typeahead = disabled

You might have to do that on more than one role, but for most people it will just be inherited from the default user role.

View solution in original post

southeringtonp
Motivator

Have you tried just editing the 'user' role and removing the capability?

In the Manager, go into Access Controls, choose Roles, and look under Selected Capabilities. You should see a capability called 'get_typeahead' -- remove it and Save.

Alternately, edit local/authorize.conf and add:

[role_user]
get_typeahead = disabled

You might have to do that on more than one role, but for most people it will just be inherited from the default user role.

Get Updates on the Splunk Community!

Welcome to the Future of Data Search & Exploration

You have more data coming at you than ever before. Over the next five years, the total amount of digital data ...

What’s new on Splunk Lantern in August

This month’s Splunk Lantern update gives you the low-down on all of the articles we’ve published over the past ...

This Week's Community Digest - Splunk Community Happenings [8.3.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...