Splunk Search

How to Combine column from multiple search results?

Niro
Explorer

Hello, I have the following search

 

 

index=wineventlog EventCode=4728 OR EventCode = 4731 OR EventCode=4729 OR EventCode=4732 OR EventCode=4756  OR EventCode=4756 NOT src_user=*$
| rename src_user as admin, name as action
| table admin, Group_Name, user_name

 

 

This spits out output like this:

 

admin	Group_Name	user_name
adminx  GroupA  	UserA
adminx 	GroupB  	UserA
adminx 	GroupC  	UserA
adminy 	GroupD  	UserB
adminy 	GroupE  	UserB
adminy 	GroupF  	UserC
adminy 	GroupF  	UserD

 

 

I'm trying to combine them into a single message that looks like this:

 

admin	Group_Name	        user_name
adminx  GroupA,GroupB,GroupC  	UserA
adminy 	GroupD,GroupE    	UserB
adminy 	GroupF  	        UserC,UserD

 

 

What would be the best way to achieve that?

Labels (3)
Tags (1)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust
| stats values(Group_Name) as Group_Name by admin user_name
| eval Group_Name=mvjoin(Group_Name, ",")
| stats values(user_name) as user_name by admin Group_Name
| eval user_name=mvjoin(user_name,",")

View solution in original post

Niro
Explorer

That worked perfectly, thank you!

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
| stats values(Group_Name) as Group_Name by admin user_name
| eval Group_Name=mvjoin(Group_Name, ",")
| stats values(user_name) as user_name by admin Group_Name
| eval user_name=mvjoin(user_name,",")
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...