Splunk Search

How to add another field using top limit command?

grotti
Engager

Hello! I need some help from splunkers!!!

 

I'm using the search index=notable | search status_label=Closed | top limit=5 rule_title in the Splunk Enterprise Security, to list top 10 rule_title values.

 

But i need to bring the field "comment" of each rule_title in the table.

 

Can please help me?

 

Tks!!!

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @grotti,

if you haven't too many comments for each row, you could use:

index=notable status_label=Closed 
| stats values(comment) AS comment BY rule_title
| sort 10 -count

Ciao.

Giuseppe

0 Karma

bowesmana
SplunkTrust
SplunkTrust

If the comment field is always the same for the rule, then just add the comment to the top command

index=notable 
| search status_label=Closed 
| top limit=5 rule_title comment
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...