Splunk Search

Help using multiple sources

tt1
Explorer

Hi, I am successfully reading and joining a couple of sources, but am having a trouble adding a 3rd.

index=access_logs TTG  | 
rex field=_raw "\"GET\s*.*?xml\?*(?<ttg_request>.*?)\s*HTTP.*?\"" | 
rex field=ttg_request "c_account_code=(?<ttg_c_account_code>.*?)&" | 
rex field=ttg_request "c_error_code=(?<ttg_c_error_code>.*?)&" |  
rex field=ttg_request "c_time_stamp=(?<ttg_c_time_stamp>.*?)&" | 
rename ttg_c_account_code as addressID | 
join addressID [search index="tt2_trial_accounts"] | 
table addressID accountCode ttg_c_error_code ttg_c_time_stamp

the 3rd

index=json_mi | table accountCode event.type date

I want to join like this;

index=access_logs OR index=json_mi |

but do not know how to handle the above rex fields in this instance.

Ideally ending up with something that looks like;

table accountCode some_field(ttg_c_error_code or event.type date) date(ttg_c_time_stamp or date)

Any help appreciated.

Tags (3)
0 Karma

Ledion_Bitincka
Splunk Employee
Splunk Employee

We need a bit more info to help with crafting the search, however generally you can use the following template to "join" data sets

<search for all the data> | <eval/extract all the needed fields> | stats <aggregates, fields ...> BY <fields you want to join>
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...