Splunk Search

Geostat remove "OTHER"

Communicator

Hi,

How can i remove the "OTHER" in geostats result ,i tried to add userother=f but its not working. Is there any other way to remove it.
Here's my sample search
index="test" |geostats latfield=lat longfield=lon latest(cpu) by city

Please enlighten me.

Thanks in Advance!
xisura

Tags (2)
1 Solution

Communicator

Hi Everyone,just found the answer. I added globallimit=0 in my search and it works.
globallimit=Controls the number of pies in the pie-chart. All other split-by values will be grouped under "OTHER".Setting globallimit=0 will remove all limits and all columns will be rendered

View solution in original post

New Member

Maybe you can try adding the fields at the end of your search:

index="test" |geostats latfield=lat longfield=lon latest(cpu) by city | fields - OTHER

As you know, it is not the best practice exclude files after doing your search, but for now you can try this solution.

I hope this will help

0 Karma

Communicator

Hi Everyone,just found the answer. I added globallimit=0 in my search and it works.
globallimit=Controls the number of pies in the pie-chart. All other split-by values will be grouped under "OTHER".Setting globallimit=0 will remove all limits and all columns will be rendered

View solution in original post

Path Finder

Thanks, this solved it for me as well. Appreciation!

0 Karma

Explorer

Thanks! I've been looking for this fix!!

0 Karma