Splunk Search

Geostat remove "OTHER"

xisura
Communicator

Hi,

How can i remove the "OTHER" in geostats result ,i tried to add userother=f but its not working. Is there any other way to remove it.
Here's my sample search
index="test" |geostats latfield=lat longfield=lon latest(cpu) by city

Please enlighten me.

Thanks in Advance!
xisura

Tags (2)
1 Solution

xisura
Communicator

Hi Everyone,just found the answer. I added globallimit=0 in my search and it works.
globallimit=Controls the number of pies in the pie-chart. All other split-by values will be grouped under "OTHER".Setting globallimit=0 will remove all limits and all columns will be rendered

View solution in original post

carlosmd
New Member

Maybe you can try adding the fields at the end of your search:

index="test" |geostats latfield=lat longfield=lon latest(cpu) by city | fields - OTHER

As you know, it is not the best practice exclude files after doing your search, but for now you can try this solution.

I hope this will help

0 Karma

xisura
Communicator

Hi Everyone,just found the answer. I added globallimit=0 in my search and it works.
globallimit=Controls the number of pies in the pie-chart. All other split-by values will be grouped under "OTHER".Setting globallimit=0 will remove all limits and all columns will be rendered

jzapantis
Path Finder

Thanks, this solved it for me as well. Appreciation!

0 Karma

Nanuk
Explorer

Thanks! I've been looking for this fix!!

0 Karma
Get Updates on the Splunk Community!

Happy CX Day to our Community Superheroes!

Happy 10th Birthday CX Day!What is CX Day? It’s a global celebration recognizing innovation and success in the ...

Check out This Month’s Brand new Splunk Lantern Articles

Splunk Lantern is a customer success center providing advice from Splunk experts on valuable data insights, ...

Routing Data to Different Splunk Indexes in the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...