Splunk Search

Filter away pattern on windows event log report

keyu921
Explorer

Current report for the following event log

index=windows  EventType=4 host=* | table _time host EventCode Message

///

EventType=4
Type=Information
ComputerName=NOYO.asus.com
Message=Installation Successful: Windows successfully installed the following update: Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.323.1450.0)

//

I try to filter away if event if message contains Security Intelligence Update for Microsoft Defender Antivirus

index=windows  EventType=4 host=*  
| where Message="%Security Intelligence Update for Microsoft Defender Antivirus%"
| table _time host EventCode Message

But seems message cannot filter

Labels (1)
0 Karma

thambisetty
SplunkTrust
SplunkTrust

Where command is used to compare two field values or check if field value is less or greater than a given number.

read about where and search commands in search reference.

https://docs.splunk.com/Documentation/Splunk/8.0.6/SearchReference/Where

 

————————————
If this helps, give a like below.
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @keyu921,

please try this:

index=windows  EventType=4 host=* Message="*Security Intelligence Update for Microsoft Defender Antivirus*"
| table _time host EventCode Message

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Build the Future of Agentic AI: Join the Splunk Agentic Ops Hackathon

AI is changing how teams investigate incidents, detect threats, automate workflows, and build intelligent ...

[Puzzles] Solve, Learn, Repeat: Character substitutions with Regular Expressions

This challenge was first posted on Slack #puzzles channelFor BORE at .conf23, we had a puzzle question which ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...