Splunk Search

Field values

obularajud16
Explorer
  •  

 

Ghj

sourcetype=access_combined | eval action = if(isnull(action) OR action="", "Unknown", action) | timechart span=40h  values(action),count(action)

 

Labels (2)
0 Karma
1 Solution

obularajud16
Explorer

Got the answer with the below

Spoiler
sourcetype=access_combined | eval action = if(isnull(action) OR action="", "unknown", action) | bin span=72h _time | stats count as totals by action, span(=_time,72h) | sort -_time,action​

View solution in original post

0 Karma

obularajud16
Explorer

Got the answer with the below

Spoiler
sourcetype=access_combined | eval action = if(isnull(action) OR action="", "unknown", action) | bin span=72h _time | stats count as totals by action, span(=_time,72h) | sort -_time,action​
0 Karma

thambisetty
SplunkTrust
SplunkTrust
sourcetype=access_combined 
| eval action = if(isnull(action) OR action="", "Unknown", action) 
| bin _time span=40h 
| chart count over _time by action
————————————
If this helps, give a like below.
0 Karma

to4kawa
Ultra Champion

sourcetype=access_combined | eval action = if(isnull(action) OR action="", "Unknown", action) | timechart span=40h count by action

0 Karma

obularajud16
Explorer

As I mentioned, i need data in row format not in column format to group by multiple fields

 

timechart span=40h count by action, status

 

 

0 Karma

isoutamo
SplunkTrust
SplunkTrust

Easiest way is combine those values like:

eval a_s = action . "-".status 

| timechart span=40h count by a_s

 

Otherwise you must start to play with bin + stats/chart/xyseries

r. Ismo

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...