Splunk Search

ES Search Help - How do I multi index join when IP address field is named differently between the two indexes?

lou_sierra
New Member

I have looked at the join documentation, but I am getting a little lost in translation.
What I am trying to accomplish, is to pull data from Index1, then join on IP address to another index to pull different information and display all of it.

Example:

 

Index=firewall dest_port=21
| stats values(dest_ip) as dest_ip values(dest_port) as dest_port sum(bytes_in) as bytes_in sum(bytes_out) as bytes_out values(app) as app values(rule) as rule by user src _time

Index=edr RPort=21 RemoteIP=$dest_ip-from-first-search

 



The output should be a table with the following:
firewall._time, firewall.src, firewall.dest_ip, edr.username, edr.username, edr.processname

The issue I am running into is the IP address field is named differently between the 2 indices.  Ideally I would join on firewall.dest_ip TO edr.RemoteIP

Any help would be appreciated. 

Labels (1)
0 Karma

smurf
Communicator

Hi,

I usually just rename the join field at the end of the subsearch or create the join field in the original search with eval.

It could look something like this:

index=firewall
| fields firewall._time, firewall.src, firewall.dest_ip
| eval edr.RemoteIP = firewall.dest_ip
| join
[ index=edr
| fields edr.username, edr.username, edr.processname edr.RemoteIP ]

 

smurf

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...

Where Innovation Takes Flight: The Splunk4Aviation Flight Sim Lands at .conf26

If you hear someone at .conf26 shouting "gear down, GEAR DOWN" across the show floor, you have found us.  The ...