Splunk Search

Download/Export all the Indexed data from Splunk cloud

Aditi27
Loves-to-Learn Lots

We have approximately a year's worth of data in our Splunk Cloud instance. Due to certain reasons, we need to export all the indexed data from Splunk Cloud into readable files. What are the possible ways to achieve this?

0 Karma

richgalloway
SplunkTrust
SplunkTrust

You could try opening a support case to see if they will export your data. 

Consider using the REST API to run queries (index=foo earliest=0 latest=now | table *) that return all the data from an index and then save that data in the desired format.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...