Splunk Search

Display the process that has top %_Processor_Time usage.

vaishnavi07
Explorer

How to display the top 10 Processes that has high %_Processor_Time.

index=winserver_process sourcetype="PerfmonMk:RunningProcesses" NOT instance=Idle NOT instance=_Total earliest=-5m@m | eval Process=upper(instance) | top Process limit=10

What does this "top Process" command do? how to find the process that has high %_Processor_Time utilization?

Does anyone know the answer? Thanks in advance!

Tags (1)
0 Karma

jameshgibson
Path Finder

You first need to sort the processes by %_Processor_time before using top. Something like

| sort - %_Processor_Time | top Process limit=10

The top command just gives you the first 10 lines of the results.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...