Splunk Search

Display data in timechart

kirrusk
Communicator

I'm using summary index to get data and display in timechart. but not able to create a time chart with the data.

index = summary_dm search_name = Instance_count | table total_Instancecount _time

(total_Instancecount, _time) these are the two fields

summary in is created by using
index = application cf_org = cf_space = cf_app = instance_index = |bucket _time span=1min| dedup cf_org cf_space cf_app instance_index | timechart span=1min count(instance_index) by cf_app| addtotals fieldname = Total_instances | fields _time Total_instances

report is scheduled using above query

summary index is populated with _time total_Instancecount.

0 Karma

woodcock
Esteemed Legend

Try this:

 index = summary_dm search_name = Instance_count
 | timechart sum(Total_instances) AS Total_instances

niketn
Legend

@kirrusk what is the frequency of your summary indexing? Also how is summary index being created? For plotting timechart what is the span you are looking for

index = summary_dm search_name = Instance_count
| timechart sum(total_Instancecount) as total_Instancecount
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

kirrusk
Communicator

summary in is created by using
index = application cf_org = * cf_space = * cf_app = * instance_index = * |bucket _time span=1min| dedup cf_org cf_space cf_app instance_index | timechart span=1min count(instance_index) by cf_app| addtotals fieldname = Total_instances | fields _time Total_instances

report is scheduled using above query

summary index is populated with _time Total_instances.

0 Karma

niketn
Legend

@kirrusk did you try the above query? Does it work for you?

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...