Splunk Search

Data Model Acceleration TSTATS where clause NOT working

simpkins1958
Contributor

The following SPL is returning multiple values for nmds_adapter_survey.iccid when the where clause is set to a value. It should only return the specified value.

| tstats
    values(nmds_adapter_survey.iccid)
    values(nmds_adapter_survey.hcar)
    values(nmds_adapter_survey.c_id)
  from datamodel=nmdm_survey
  where nmds_adapter_survey.iccid="89014103255440210384"

Results:
alt text

Setting the where clause to any numbers for the last 4 characters returns what matches the first 16 characters. The where clause below returns the same values as the SPL where clause above.

 where nmds_adapter_survey.iccid="89014103255440210000"

In the data model the iccid value is defined as a string.

gabriel_vasseur
Contributor

We've just witnessed the exact same issue for us. Looks like tstats will return results if the first 16 characters are the same, ignoring any change beyond that. Unbelievable.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Analytics Workspace removal in Splunk 10.6

In Splunk Cloud Platform and Splunk Enterprise 10.6, Analytics Workspace is removed from product and no longer ...

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...