Splunk Search

Calculate time difference between two events

priya1926
Path Finder

Hi All,

 

I am using the below search to calculate time difference between two events ie., 6006 and 6005

6006 is event start time and 6006 is event stopped time. If we find the difference we will get to know the downtime of the system.

This is what i have tried. To few systems it is right and for few it is wrong.


index="wineventlog" host IN (xxxx) EventCode=6006 OR EventCode="6005" Type=Information
| stats latest(_time) as StartUp by host
| join host
[ search index="wineventlog" host IN (xxxx)
| stats latest(_time) as Shutdown by host ]
| eval difference=StartUp-Shutdown
| eval humanTime = strftime(difference*86400)
| table host humanTime

Thanks in advance 🙂

Labels (3)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

I don't understand the logic of this query.  If either a 6005 or a 6006 is received then it is considered a "startup" and if any other event is received from the same host then it is a "shutdown".  Should one event code indicate a startup and the other a shutdown?

Perhaps this query will help.

 

index="wineventlog" host IN (xxxx) EventCode=6006 OR EventCode="6005" Type=Information
| stats earliest(_time) as Shutdown, latest(_time) as Startup by host
| eval Downtime=tostring(Startup-Shutdown, "duration")
| table host Shutdown Startup Downtime
| fieldformat Shutdown=strftime(Shutdown,"%c")
| fieldformat Startup=strftime(Startup,"%c")

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

I don't understand the logic of this query.  If either a 6005 or a 6006 is received then it is considered a "startup" and if any other event is received from the same host then it is a "shutdown".  Should one event code indicate a startup and the other a shutdown?

Perhaps this query will help.

 

index="wineventlog" host IN (xxxx) EventCode=6006 OR EventCode="6005" Type=Information
| stats earliest(_time) as Shutdown, latest(_time) as Startup by host
| eval Downtime=tostring(Startup-Shutdown, "duration")
| table host Shutdown Startup Downtime
| fieldformat Shutdown=strftime(Shutdown,"%c")
| fieldformat Startup=strftime(Startup,"%c")

 

---
If this reply helps you, Karma would be appreciated.

priya1926
Path Finder

Thanks that helped 🙂

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Character substitutions with Regular Expressions

This challenge was first posted on Slack #puzzles channelFor BORE at .conf23, we had a puzzle question which ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...