Splunk Search

CPU Usage by Process

Kendo213
Communicator

Is there a way to pull a list of running processes and the CPU % usage per process via Splunk natively? Using Powershell isn't proving to be that useful. For example, get-process | select name,CPU will give you the CPU time, but not the CPU percentage. Various scripts I've tried aren't successful at converting to a percentage.

Tags (1)
0 Karma

hortonew
Builder

inputs.conf

[perfmon://Process]
object = Process\(*
counters = *
instances = *
index = perfmon
interval = 30
disabled = 0

index=perfmon object=Process counter="% Processor Time" instance!=_Total instance!=Idle | stats latest(Value) as Value by host, instance

Turns nicely into Trellis pie chart

Edit: formatting to code to maintain backslash->paren

somesoni2
Revered Legend
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...