Splunk Search

CEF Field Parsing

riqbal47010
Path Finder

I am not seeing extracted field against below query.

index=fireeye | eval {flexString2Label} = flexString2

below are crossponding values in CEF format
flexString2Label = subjcect

flexString2 = "a test message"

Please advise that what I a missing

Labels (1)
Tags (2)
0 Karma
1 Solution

to4kawa
Ultra Champion
| makeresults 
| eval flexString2Label = "subject",flexString2 = "a test message" 
| eval {flexString2Label} = flexString2

this is OK.
maybe, flexString2Label OR flexString2 field does not extracted.

View solution in original post

0 Karma

to4kawa
Ultra Champion
| makeresults 
| eval flexString2Label = "subject",flexString2 = "a test message" 
| eval {flexString2Label} = flexString2

this is OK.
maybe, flexString2Label OR flexString2 field does not extracted.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...