Splunk Enterprise

multisearch and lookup

KevinIron1
Observer

I want to do a multi-search on various systems looking for the src_ip and comparing that src_ip from those systems to a threat intel feed lookup (KV store). When I run the SPL, I get the following error: Multisearch subsearches might only contain purely streaming operations (subsearch 1 contains a non-streaming command). This is the lookup: lookup TF-ip-add indicator as src_ip OUTPUTNEW

Labels (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

If the search returns a multisearch error then why are you telling us about a lookup?  Please share the full query or at least the first subsearch in the multisearch.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...