Splunk Enterprise

Why is scripted input not showing up in search results, but is running fine in server?

akgmail
Explorer

Scripted input not showing up in search results, but is running fine in server

Labels (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

That's not a lot to go on.  Make sure you're searching the right index and time window.  How are you determining the SI is running fine?  Does _internal show the script is launched?  Are there any conditions where the script might "run fine", but produce no output?

---
If this reply helps you, Karma would be appreciated.
0 Karma

akgmail
Explorer

The script is producing output when i run the script located at  /opt/splunkforwarder/etc/apps/custom_app/bin  in UF but it is not sending data to HF.

UF is configured in a way that it forwards data to HF and then to IDXer.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

How did you determine the UF is not send data to the HF?  Make sure you're searching the right index and time window. 

Do you see the UF's internal logs in the search head?  Does _internal show the script is launched?

---
If this reply helps you, Karma would be appreciated.
0 Karma

somesoni2
Revered Legend

Check if you see any error in the internal logs from the server where scripted input is running

index=_internal error yourscriptnamehere
0 Karma
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...