Splunk Enterprise

Splunk Macro

verifi81
Path Finder

I have this SPL

index="_internal" fwdType=uf | dedup hostname | table hostname

I want to create a macro called uf 

I have the macro created like this:

verifi81_0-1628816488766.png

 

I want to be able to just execute this macro in search but it doesn't look the same as if I execute the full command.

verifi81_1-1628816553225.png

 

What am I doing wrong?

 

Labels (1)
0 Karma
1 Solution

venkatasri
SplunkTrust
SplunkTrust

Hi @verifi81 

You mean its not working, the macro shall be as this , what you are using is single quote that doesn't work. 

`uf`

  

View solution in original post

0 Karma

venkatasri
SplunkTrust
SplunkTrust

Hi @verifi81 

You mean its not working, the macro shall be as this , what you are using is single quote that doesn't work. 

`uf`

  

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...