Splunk Enterprise

Splunk 8.1.2 Python problem

eduardo89
Explorer

Dear all,

How many of you faced the issue that Intersplunk library drops this error:

AttributeError: module 'splunk.util' has no attribute 'OrderedDict'

In the commands.conf I did not specify the python version.
If I specify python version 2 the script is working.
But here comes the other funny thing that splunk util file is the same in both site-package folder so I do not really understand what is going on here.
By the way the same script is working fine in 8.1.1 no matter which version I provide in commands.conf file.
Thanks,

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Try reporting it at https://ideas.splunk.com

---
If this reply helps you, an upvote would be appreciated.

View solution in original post

Lovekesh28
Observer

Python could be a completely practical programming language that will do something virtually the other language can do, at comparable speeds. Python is capable of threading and GPU processing just like the other language. Most of the information process modules are literally simply Python wrappers around C/C++ code.
Python Training in Pune

0 Karma

eduardo89
Explorer

And I think this should be reported to Splunk, because it will affect all applications which use Intersplunk.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Sounds like a bug.  File a support request.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

eduardo89
Explorer

Thanks for the reply but I have no license to file a support ticket.
I am using only Splunk Enterprise Trial version.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try reporting it at https://ideas.splunk.com

---
If this reply helps you, an upvote would be appreciated.

View solution in original post

eduardo89
Explorer

Thank you! 🙂

0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!