Splunk Enterprise

SAML SSO idp cert cannot be found

vennemp
Observer

I've configured okta with splunk a dozen times.  However this time it keeps telling me that:

 

Failed to load trusted certificate: Error: failed to load pem certificate. Verify the full path including the filename is correct and points to the certificate from the IDP.

and in logs:

Saml - Unable to load cert(s) from path="/opt/splunk/etc/auth/idpCerts/idpCert.pem".

 

But the cert exists there and splunk has ownership of the full and the entire path to the file.  What gives??

Labels (1)
Tags (2)
0 Karma

DaveMack
Engager

@vennemp @Anurag_Byakod 

I had this same problem and it stemmed from certificate file formatting. I ended up running an

openssl x509 -in idpCert.pem -out idpCert1.pem

And I pointed the SAML config at the idpCert1.pem, reloaded auth, logged out of the admin account and I was logged right in. 

After diff-ing the two, it seems that when copying and pasting (into cat, in my case) the cert info from Okta, it doesn't maintain the format. And while running an openssl x509 -in idpCert.pem -noout -text _will_ give you the correct output for the cert, something in Splunk barfs when it sees the bad formatting. Outputting it to a new pem using openssl formats it correctly. 

Good luck

Tags (2)
0 Karma

Anurag_Byakod
Observer

Hi @vennemp 

Were you able to get the issue fixed? I am facing the same issue with OKTA Splunk SAML integration.

Tags (2)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...