Splunk Enterprise Security

setup.xml exists for apps, but no "Setup app" option

cdhippen
Path Finder

We've tried installing several apps on a distributed search head cluster via a deployer:

Demisto:
https://splunkbase.splunk.com/app/3447/
https://splunkbase.splunk.com/app/3448/

Sophos:
https://splunkbase.splunk.com/app/3612/
https://splunkbase.splunk.com/app/1854/

are two examples. I was initially able to load the setup and take screenshots of all of the requirements but going back in, none of the setup pages are showing. I tried reinstalling demisto from a fresh tgz file but the setup page is still not showing up.

I've checked app.conf and the necessary apps are visible, and I checked that they're set as not yet configured, and they all have setup.xml files in their root directory.

Something to note, this is an ES search head cluster.

0 Karma
1 Solution

manjunathmeti
SplunkTrust
SplunkTrust

Please make sure that you enabled Show All Settings(if it's a clustered stack).

alt text

View solution in original post

manjunathmeti
SplunkTrust
SplunkTrust

Please make sure that you enabled Show All Settings(if it's a clustered stack).

alt text

cdhippen
Path Finder

This did it! Any idea why that would be hidden for some apps but not others when show all settings is turned off?

0 Karma

manjunathmeti
SplunkTrust
SplunkTrust

App setup is a non-Knowledge setting and Splunk hides this since cluster only replicates certain setting changes. Please note that if you make a change to a hidden setting, the changed configuration will exist only on the cluster member where you made the change. If you want other members to get that change as well, you must use the deployer to push the underlying configuration file for that setting.

0 Karma

nickhills
Ultra Champion

As the author of https://splunkbase.splunk.com/app/3612/ I just want to say that app has not been updated since 2018 🙂

It uses the is_configured flag in ./local/app.conf to decide if it should show the setup page.
If you want to see the setup page again remove that setting (or set to 0), restart and open the app.

If my comment helps, please give it a thumbs up!
0 Karma

cdhippen
Path Finder

I mentioned in my post that I checked those variables in the app.conf files and they are set to 0 (not configured). I did not change them.

0 Karma

cdhippen
Path Finder

Also, this is happening on multiple apps, some of which have been updated recently. I don't believe it to be an issue with the apps, but the environment itself

0 Karma
Get Updates on the Splunk Community!

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...

Ready, Set, SOAR: How Utility Apps Can Up Level Your Playbooks!

 WATCH NOW Powering your capabilities has never been so easy with ready-made Splunk® SOAR Utility Apps. Parse ...