Splunk Enterprise Security

Splunk Enterprise Security: How to modify the Top Infections Search to exclude results where signature=Tracking Cookies?

kmcaloon
Explorer

Can someone help me modify the Top Infections search? It is using tstats and a datamodel. I'm trying to exclude results where signature=Tracking Cookies, but usual exclusion methods aren't working with tstats and datamodel. The dashboard search is below.

| tstats `summariesonly` dc(Malware_Attacks.dest) as dest_count from datamodel=Malware where *    by Malware_Attacks.signature | `drop_dm_object_name("Malware_Attacks")` | sort 10 - dest_count

This search results in a chart with the signature name in one column and dest_count in the next column. I would like to exclude results that match on signature that equals "Tracking Cookies".

0 Karma

mcronkrite
Splunk Employee
Splunk Employee

Look at your data that is tagged Malware, and Attack.
This is what is being collected to include.

So you need to modify the event type for the tags, malware and attack, and add to that search to exclude the data you don't want.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...