Splunk Enterprise Security

Recorded future app missing session key

jerm1020rq
Explorer

When searching for sourcetype=recorded future IOCS, i receive the following error. I updated the API key and that fixed the issue of not being able to authenticate but now I am receiving this error. Is there somewhere within the config i need to stop the script from being started via Command line?

No session key was provided by the Splunk server. This can happen if the script is started from the command line which is not supported.
Traceback (most recent call last):
File "/opt/splunk/etc/apps/TA-recorded_future/bin/get-rf-threatlists.py", line 186, in main
session_key = rf_splunk.api_key.get_session_key()
File "/opt/splunk/etc/apps/TA-recorded_future/bin/rf_splunk/api_key.py", line 85, in get_session_key
raise MissingSessionKeyError('No session key was provided by the '
MissingSessionKeyError: No session key was provided by the Splunk server. This can happen if the script is started from the command line which is not supported.

0 Karma

ess
New Member

There is not enough data here to analyze the issue. Please open a support ticket through your support channel at Recorded Future.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Analytics Workspace removal in Splunk 10.6

In Splunk Cloud Platform and Splunk Enterprise 10.6, Analytics Workspace is removed from product and no longer ...

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...