Splunk Enterprise Security

Passing fields into multiple searches w/out using Map Cmd

McThunderStick
Engager

*I would typically use the map command for this, but it's currently broken and support is working to fix it

That being said, I'm trying to take a value from search1, pass it to search2 , grab  a field from that 2nd search, and also pass that to 3rd search. Hopefully one of you lovely people can point me in the right direction.

IE:

index=foo | rex field field1

index=boo field2=$field1$ | table src_ip

index=bar src_ip=$src_ip$ | stats  values(domain) etc etc

 

Any help on this would be supremely appreciated

Labels (1)
Tags (2)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

It looks like subsearches may do the job.

index=bar 
  [ index=boo 
    [index=foo | rex field field1 | rename field1 as field2 | format]
  | return src_ip ]
| stats  values(domain) etc etc
---
If this reply helps you, Karma would be appreciated.

View solution in original post

to4kawa
Ultra Champion

index=foo OR index=boo OR  index=bar | rex field field2|eventstats dc(index) as flag1 by field2 |  stats  values(domain) etc etc dc(index) as flag values(flag1) as flag1 by src_ip |where flag1=2 AND flag > 1

0 Karma

richgalloway
SplunkTrust
SplunkTrust

It looks like subsearches may do the job.

index=bar 
  [ index=boo 
    [index=foo | rex field field1 | rename field1 as field2 | format]
  | return src_ip ]
| stats  values(domain) etc etc
---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...