Splunk Enterprise Security

Enterprise Security: How to get a field break-down for a Web datamodel?

danielbb
Motivator

I'm looking at the Web datamodel and try to determine which fields are populated.

I can do :
| tstats dc(sourcetype) FROM datamodel=Web by sourcetype
and | tstats count(sourcetype)
FROM datamodel=Web by sourcetype
or
| tstats count(Web.status) FROM datamodel=Web by Web.status

but I like to see a breakdown of all the fields in this datamodel.

Is it possible?

0 Karma

ChrisG
Splunk Employee
Splunk Employee

You can refer to the Common Information Model documentation. See https://docs.splunk.com/Documentation/CIM/4.13.0/User/Web.

0 Karma

danielbb
Motivator

I know the field names @ChrisG, if this is what you meant, but I like to see a breakdown of the fields, since there are quite a bit of them.

0 Karma

ChrisG
Splunk Employee
Splunk Employee

I guess I'm not sure what you mean by "breakdown." The doc lists the field names, data type, description, and example values. Can you clarify your question, to help the community answer better?

0 Karma

danielbb
Motivator

Sure, I would like to see which fields are populated with which values across all the fields which are available in this datamodel, without examining each field individually. I hope it's clear.

0 Karma

danielbb
Motivator

I guess the pivot is a good place to explore the datamodel.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...