Splunk Enterprise Security

Alert not triggering

miguelangelclem
Explorer

Hi all,

I have created an alert with this simple query:

index=foo host="bar" action=fail | stats count by user | search count>40 

It is scheduled every hour and the trigger setting is Number of Results greater than 0

I have tried adding table and fields commands but it still doesn't work

Why could this happen?

0 Karma
1 Solution

harishalipaka
Motivator
0 Karma

harishalipaka
Motivator
0 Karma

memarshall63
Communicator

What is your search time frame?
A user would have to fail 40 times within your search time frame to qualify as an alert.

Is that what you're expecting?

0 Karma

miguelangelclem
Explorer

Yes, I am expecting that.

I have found the problem and was the email configuration as @harishalipaka tell me. The alerts didn't appear because i had not set the action, and the email wasn't sending for a misconfiguration in server.

Thanks!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...