Splunk Dev

help on under label token

jip31
Motivator

Hi

 

 

 <search>
<query>index=* EventCode=25753 
| stats count(EventCode) as toto 
| append 
    [| search index=* EventCode=* 
    | stats count(EventCode) as toto2]</query>
          <earliest>-7d@h</earliest>
          <latest>now</latest>
            <done>
             <condition>
               <set token="NbHost">$result.toto$</set>
               <set token="NbHost2">$result.toto2$</set>
             </condition>
           </done>
        </search>
        <option name="drilldown">none</option>
        <option name="underLabel">$NbHost$ / $NbHost2$</option>

 

I dont succeed to display the NbHost2 value under my single panel

what is wrong please?

jip31_0-1721121339609.png

 

 

Tags (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

The underlabel option does not perform evaluations.  Do the eval in a separate statement.

 <search>
<query>index=* EventCode=25753 
| stats count(EventCode) as toto 
| append 
    [| search index=* EventCode=* 
    | stats count(EventCode) as toto2]</query>
          <earliest>-7d@h</earliest>
          <latest>now</latest>
            <done>
             <condition>
               <set token="NbHost">$result.toto$</set>
               <set token="NbHost2">$result.toto2$</set>
               <eval token="ratio">$NbHost$ / $NbHost2$</eval>
             </condition>
           </done>
        </search>
        <option name="drilldown">none</option>
        <option name="underLabel">$ratio$</option>
---
If this reply helps you, Karma would be appreciated.
0 Karma

jip31
Motivator

i have anything displayed under label...

is anybody can help?

Here is what i see

jip31_0-1721311408427.png

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Build resilience for the agentic era: Join us at Splunk Go San Jose

AI is changing how organizations build, operate, and secure digital services. As teams adopt AI agents and ...

Manage Edge Processor pipelines end to end with APIs

This guide uses the Data Management APIs to create an Edge Processor, onboard one instance, deploy a pipeline ...

Splunk Brings Proof of Control to Digital Asset Transfers

Digital assets now sit inside the core of financial services. HSBC launched its Tokenized Deposit Service in ...