Splunk AppDynamics

configuration error: app name required

shubham_thakur
New Member

Hello,

I have to setup appdynamic with ruby on rails, I have added gem "gem 'appdynamics' " in gemfile, also created appdynamics.yml file with following details:

app_name: "My app name"
tier_name: "ROR"
node_name: "test"
controller:
host: "test"
port: "test"
account: "test"
access_key: "some key"

Also Please Do Let Me know How Will I get  app_name, tier_name, node_name, controller, host, port, account, access_key.

I am getting this error:
1) WARN -- AppDynamics: Unable to start Instrumenter due to a configuration error: app name required
2) AppDynamics: [AppDynamics] [1.1.2] Running AppDynamics in development mode. No data will be reported until you deploy your app.

can anyone help me for this ???

Labels (1)
Tags (2)
0 Karma

millerep
Contributor

Since you're using a config file (.yml) and not the env, make sure you're using the correct syntax, I don't think you use " in .yml. Also, I'm assuming in your code, you're actually passing a correct port, account and access key, and not just "test?"

 Here's the documentation which may help: https://docs.appdynamics.com/display/RUBY/Install+the+Ruby+Agent

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...