Splunk AppDynamics

ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.

APG_Monitoring_
New Member

Hi Team,

We have installed AppDynamics java agent on IBM Cloud servers on Linux boxes. The agents were successfully installed as well as we are getting metrics but we have a problem on the agent side.

We’re seeing the below error on server startup related to appdynamics. Do you know what this means? How do we resolve it?

INFO   | jvm 1    | main    | 2020/05/01 04:38:22.310 | Install Directory resolved to[/export/home/AppDynamics/AppServerAgent]
INFO   | jvm 1    | main    | 2020/05/01 04:38:22.610 | ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.
INFO   | jvm 1    | main    | 2020/05/01 04:38:22.811 | Exception caught : java.
util.zip.ZipException: error in opening zip file trying to preload agent classes
INFO   | jvm 1    | main    | 2020/05/01 04:38:22.811 | java.util.zip.ZipException: error in opening zip file

I have also disabled  - "Detect errors logged using Log4j" from AppDynamics Console in the Error Detection Tab 

Please help

Labels (1)
0 Karma

iamryan
Community Manager
Community Manager

Hi @APG Monitoring Team.APG Monitoring Team,

What version of the java agent are you using?

0 Karma

APG_Monitoring_
New Member

Hi Ryan, We are using 4.5.17

0 Karma

iamryan
Community Manager
Community Manager

Hi @APG Monitoring Team.APG Monitoring Team,

Thanks for that info. Looks like there is a newer version available 20.4 if you are willing to try that.

You can see the newer versions here

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...