Why does my Splunk Web interface stop responding after a few hours?

Path Finder

Hello Splunkers,

I seem to be having an issue where the web interface stops responding after a few hours. I then must issue "splunk restart" to bring it back but it stops working again after awhile. It is still indexing during that time. It's just that the web interface will not respond until I restart Splunk.

Thanks in advance. Other info below.

Splunk status when it is not working shows: "Splunkd: Running (pid ###)"

After Splunk restarts, it shows the same thing with a different PID number.

Splunkd is the only thing it lists in either case.

After the restart is complete the the web interface works just fine. For awhile.

OS: Win 10 Pro

0 Karma

Path Finder

I think I found the issue. We recently updated to Avast Business Pro antivirus. This version has it's own firewall that DID NOT copy existing exceptions from Windows Defender firewall. Creating exceptions in Avast did not resolve the issue. After several posts on the Avast help forum, the easiest (only?) way to fix this is to turn off Avast firewall and revert to Windows Defender firewall.

After doing this, Splunk works as intended until Avast is restarted and automatically re-enables the firewall. To prevent this you must (from the Avast management console) create a new settings template with Avast firewall disabled and apply it to the Splunk server.

Hope this helps others that may run in to this same issue.
Happy Splunking.

Splunk>Your data.

Get Updates on the Splunk Community!

Splunk Observability Cloud | Customer Survey!

If you use Splunk Observability Cloud, we invite you to share your valuable insights with us through a brief ...

Happy CX Day, Splunk Community!

Happy CX Day, Splunk Community! CX stands for Customer Experience, and today, October 3rd, is CX Day — a ...

.conf23 | Get Your Cybersecurity Defense Analyst Certification in Vegas

We’re excited to announce a new Splunk certification exam being released at .conf23! If you’re going to Las ...