Security

Problem with scripted authentication

sgp0637
Engager

We are using scripted authentication in Splunk using credentials of a central system. This works fine for 4 users out of 5 who have same role, same privileges and same index assigned.

However for one user, splunk web throws *500 Internal Server Error *. After enabling the debug, the scripted authentication is 'successful' including all three functions ie; userLogin,getUserInfo,getUsers. However, once its submitted to splunkd, it throws the error AdminHandler:AuthenticationHandler - Insufficient permissions to list user:<username>

The user has exactly same privileges as others.

Please share if you have experienced same issue and a possible solution if any.

Thanks

0 Karma
1 Solution

renjith_nair
Legend

Check if the user login as a space at the beginning or end.

---
What goes around comes around. If it helps, hit it with Karma 🙂

View solution in original post

0 Karma

renjith_nair
Legend

Check if the user login as a space at the beginning or end.

---
What goes around comes around. If it helps, hit it with Karma 🙂
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...