Security

Logon Failures - Different User Accounts - Same Workstation IP

itsmevic
Communicator

Hi,

 Does anyone have any SPL that looks at multiple logon failures utilizing event codes 672, 675, 676, 4768 and 4771?  The parameters behind this query would be: 

1.) Where client address is the same
2.) But the username is different
3.) Within X minutes

index=wineventlog sourcetype=* EventCode="672" OR "675" OR "676" OR "4768" OR "4771"
| table _time src user
Tags (2)
0 Karma

gfreitas
Builder
index=wineventlog sourcetype=* EventCode="672" OR "675" OR "676" OR "4768" OR "4771"
| stats values(username) as usernames, dc(username) as user_num by src_ip
| where user_num > 1

Above should work, just make sure there is a src_ip on your data otherwise change it to the desired IP field

0 Karma

nickhills
Ultra Champion

Add this to the end of your query

|timechart dc(user) as failedUsers by src span=15m|where failedUsers>1

Does that get you close to what you are after?

If my comment helps, please give it a thumbs up!
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Guided Onboarding with Auto-schema Is Now Generally Available

  We are excited to announce the General Availability of Guided Onboarding with Auto-Schematization ...

ATTENTION: We’re Moving! (AGAIN!)

The Splunk Community Slack is undergoing a system migration to keep our workspace secure and ...

Deep Dive: Optimizing Telemetry Pipelines in Splunk Observability Cloud

In this session, we will peel back the layers of Splunk Observability Cloud’s cost-optimization features. ...