Security
Highlighted

FIPS enabled. What is the correct path form in server.conf (kvstorestanza) for SSLKeysPath?

Explorer

I have FIPS enabled in Splunk 6.2.1 Windows 2008R2 64bit. The kvstore stanza is required to be defined in the server.conf file when in FIPS mode. When I start Splunk the Splunk.d log shows that it cannot "find" the certs and keys for the kvstore. I am referring to caCertPath and sslKeysPath. I have tried the full absolute paths and relative paths. What is the correct path form for these parameters? Thank you.

Tags (3)
0 Karma
Highlighted

Re: FIPS enabled. What is the correct path form in server.conf (kvstorestanza) for SSLKeysPath?

Explorer

Found the answer:

[kvstore]
disabled = false
caCertPath = F:/Program Files/Splunk/etc/auth/
sslKeysPassword =
sslKeysPath = F:/Program Files/Splunk/etc/auth/

View solution in original post