Security

FIPS enabled. What is the correct path form in server.conf (kvstorestanza) for SSLKeysPath?

e2eadmin
Explorer

I have FIPS enabled in Splunk 6.2.1 Windows 2008R2 64bit. The kvstore stanza is required to be defined in the server.conf file when in FIPS mode. When I start Splunk the Splunk.d log shows that it cannot "find" the certs and keys for the kvstore. I am referring to caCertPath and sslKeysPath. I have tried the full absolute paths and relative paths. What is the correct path form for these parameters? Thank you.

Tags (3)
0 Karma
1 Solution

e2eadmin
Explorer

Found the answer:

[kvstore]
disabled = false
caCertPath = F:/Program Files/Splunk/etc/auth/
sslKeysPassword =
sslKeysPath = F:/Program Files/Splunk/etc/auth/

View solution in original post

e2eadmin
Explorer

Found the answer:

[kvstore]
disabled = false
caCertPath = F:/Program Files/Splunk/etc/auth/
sslKeysPassword =
sslKeysPath = F:/Program Files/Splunk/etc/auth/

View solution in original post

Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.