Security

FIPS enabled. What is the correct path form in server.conf (kvstorestanza) for SSLKeysPath?

e2eadmin
Explorer

I have FIPS enabled in Splunk 6.2.1 Windows 2008R2 64bit. The kvstore stanza is required to be defined in the server.conf file when in FIPS mode. When I start Splunk the Splunk.d log shows that it cannot "find" the certs and keys for the kvstore. I am referring to caCertPath and sslKeysPath. I have tried the full absolute paths and relative paths. What is the correct path form for these parameters? Thank you.

Tags (3)
0 Karma
1 Solution

e2eadmin
Explorer

Found the answer:

[kvstore]
disabled = false
caCertPath = F:/Program Files/Splunk/etc/auth/
sslKeysPassword =
sslKeysPath = F:/Program Files/Splunk/etc/auth/

View solution in original post

e2eadmin
Explorer

Found the answer:

[kvstore]
disabled = false
caCertPath = F:/Program Files/Splunk/etc/auth/
sslKeysPassword =
sslKeysPath = F:/Program Files/Splunk/etc/auth/

Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...