Security

Application not viewable from splunkweb

Communicator

Hello,

We have an application called "F2B_Env", this used to work, but now when we try to open it from splunk web, we see the following error

404 Not Found
App "webping" does not support UI access. See its app.conf for more information.

I am not sure why this error is showing up. I have checked the webping application and checked that its app.conf has is_visible = false and no reference to the F2B_Env. I have also checked the F2B_Env app and can find no reference to webping.

I have no idea how the webping is affecting it, does anyone have any ideas?

To add, these are both applications that are run by our indexer. One should appear in splunk web, the other should not. I am really just looking for tips from people of things they'd check to see why it wasn't working?

Thanks 🙂

Tags (2)
0 Karma
1 Solution

Communicator

The problem was due the [ui] stanza being misconfigured on the F2B_Env app. I rewrote this and it is now working 🙂

View solution in original post

Communicator

The problem was due the [ui] stanza being misconfigured on the F2B_Env app. I rewrote this and it is now working 🙂

View solution in original post

Splunk Employee
Splunk Employee

Apps may not be viewable for a few reasons, but I would do the following:

Check the app settings that Splunk thinks it has:

> ./splunk display app

The settings such as is_visible should be shown from this output.

If the app worked in 4.0, it should be portable to 4.1 for the most part. If you are moving a 3.x app to 4.x, that will likely not work.

0 Karma

Splunk Employee
Splunk Employee

Sounds like a bug. I'd send a diag to support so they can reproduce.

0 Karma