Security

Account locked out

Gayathirik
Path Finder

index=winsec EventCode="4624" | dedup user| stats count as total by _time host user src_ip

The above query wrks fine for extracting the sourceip for acccount logged on.

But!!

index=winsec EventCode="4740" | dedup user| stats count as total by _time host user src_ip is not working to extarct the ip address of the machine that got account locked out.

Tags (1)
0 Karma
1 Solution

inventsekar
SplunkTrust
SplunkTrust

i just checked, the Event ID 4740 is not capturing the source ip's. its collecting only Computer names (host gives short hostname, ComputerName gives the FQDN).

index=winsec EventCode="4740" | dedup user| stats count as total by _time host user ComputerName

maybe, from ComputerName, you can do a dnslookup.

updated - to get src_ip, maybe a subsearch will help -

index=winsec [search index=winsec EventCode="4740" | dedup user| table ComputerName] | stats count as total by _time host user src_ip

View solution in original post

inventsekar
SplunkTrust
SplunkTrust

i just checked, the Event ID 4740 is not capturing the source ip's. its collecting only Computer names (host gives short hostname, ComputerName gives the FQDN).

index=winsec EventCode="4740" | dedup user| stats count as total by _time host user ComputerName

maybe, from ComputerName, you can do a dnslookup.

updated - to get src_ip, maybe a subsearch will help -

index=winsec [search index=winsec EventCode="4740" | dedup user| table ComputerName] | stats count as total by _time host user src_ip

Gayathirik
Path Finder

Yes, i have already used with computer name still i need to extract the sourceip that would give evn more clarification when the account is locked from a particular src_ip rather than computername..

0 Karma

inventsekar
SplunkTrust
SplunkTrust

to get src_ip, maybe a subsearch will help -

index=winsec [search index=winsec EventCode="4740" | dedup user| table ComputerName] | stats count as total by _time host user src_ip

Gayathirik
Path Finder

This really wrks!!!Thanks a lot!!!

0 Karma

inventsekar
SplunkTrust
SplunkTrust

Hi Gayathri, can you please mark this as the accepted answer (and (few) upvotes please 😉 )

jpolcari
Communicator

The src_ip is NOT available from Event ID 4740

More info: https://www.ultimatewindowssecurity.com/securitylog/encyclopedia/event.aspx?eventID=4740

If you are looking for more information on what caused the lockout, you would need to look more into the failed logon attempts that lead up to the lockout.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOK it to Me: Top 3 Benefits of Using Splunk Operator on Kubernetes that’ll Make ...

    Thursday, July 9, 2026  |  11:00AM–12:00PM PDT Duration: 1 hour (includes Q&A) Managing can feel like a ...

Upgrade Prep for 10.4, Network Observability Deep Dives, and More from Splunk Lantern

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Splunk Developer Day announcements: AI agents, MCP tools, Forecasting, and Custom ...

Splunk Developer Day was packed with product and platform updates for developers building in the AI ...