Reporting

splunk-6 pdf generation

Communicator

Hi everyone.
I've got a problem with chart legends while generating pdf: long labels are being replaced with "...".
Is there any way to put it in different rows or view some leading (about 15) characters or anything else?

Tags (3)
0 Karma
1 Solution

Splunk Employee
Splunk Employee

If you add this to your panel XML you can disable the legend label truncation:

<option name="charting.legend.labelStyle.overflowMode">ellipsisNone</option>

View solution in original post

Splunk Employee
Splunk Employee

If you add this to your panel XML you can disable the legend label truncation:

<option name="charting.legend.labelStyle.overflowMode">ellipsisNone</option>

View solution in original post

Splunk Employee
Splunk Employee

It's in the docs, but a little buried (charting options are a hard thing to document well):

http://docs.splunk.com/Documentation/Splunk/latest/Viz/ChartConfigurationReference#General_chart_pro...

0 Karma

Communicator

victory 🙂 great, thanks. where did you get this?

0 Karma