Reporting
Highlighted

Unable to use sendemail

Path Finder

Hi all,

I need to trigger a email whenever am opening a internet explorer.So i have tried with sendemail but failed to achieve that and details below on erros;

reg host="D-24964" Microsoft "expl.exe" | sendemail to="balaji.s@nln.com" server=chp-outlook.nln.com="" use_ssl=true username="balaji.s@nln.com="" user="" name=""" password="balaji.s@nln.com="" password=""" sendresults=true

when am running above sendemail query, am getting the error "command="sendemail", [Errno 11004] getaddrinfo failed while sending mail to: balaji.s@nln.com

also if am trying run another simple query like below ;
reg host="D-24964" Microsoft "expl.exe" | sendemail to="balaji.s@nln.com" server=chp-outlook.nln.com sendresults=true

Then geting the below error;
command="sendemail", [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond while sending mail to: balaji.s@nln.com

Also i have tried with enable or disble of ssl/tsl in IE settings.Still its not working.

Please help.

Balaji

Tags (1)
Highlighted

Re: Unable to use sendemail

SplunkTrust
SplunkTrust

Hi balajsoz,

The first error is because the sendemail.py script cannot getaddinfo for server=chp-outlook.nln.com="", see this for more info.

The second error is because your mail server chp-outlook.nln.com probably does not accept your request to send an email, see this for more info.

Both errors are not Splunk errors 😉

cheers, MuS

Highlighted

Re: Unable to use sendemail

Path Finder

I have tried below search query to send mail to my gmail id, after came out of firewall boundry;

<>>

and am getting the error-->. "command="sendemail", (530, '5.7.0 Must issue a STARTTLS command first. u1sm53537353ige.1 - gsmtp', 'splunk@D-24964') while sending mail to: balain@gmail.com "

Please suggest to fix this.

0 Karma
Highlighted

Re: Unable to use sendemail

SplunkTrust
SplunkTrust

This is the reply the gmail server gave you, so read the message and you will find Must issue a STARTTLS command first. Have you tried it with the start_ssl option?

0 Karma