Reporting

Active Directory: Alert When a Group is Added to a User

itsmevic
Communicator

I need to create a report that alerts on the following:

I'd like to know when and by who added a specific group to a user in AD.

Any insight or help is greatly appreciated.

Tags (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust
0 Karma

itsmevic
Communicator

Hi Giuseppe, we capture the following Group event codes in our environment. I just need the SPL that identifies the alert on my initial question. Thanks.

Event 4727 A Security-enabled Global Group was created

Event 4737 A Security-enabled Global Group was changed (generico precede ogni operazione che modifica le caratteristiche del gruppo)

Event 4728 A member was added to a security-enabled Global group

Event 4729 A member was removed from a security-enabled Global group

Event 4730 A Security-enabled Global Group was removed

Event 4754 A Security-enabled Universal Group was created

Event 4755 A Security-enabled Universal Group was changed (generico precede ogni operazione che modifica le caratteristiche del gruppo)

Event 4756 A member was added to a security-enabled Universal group

Event 4757 A member was removed from a security-enabled Universal group

Event 4758 A Security-enabled Universal Group was removed

Event 4731 A Security-enabled Local Group was created

Event 4735 A Security-enabled Local Group was changed (generico precede ogni operazione che modifica le caratteristiche del gruppo)

Event 4732 A member was added to a security-enabled Domain Local group

Event 4733 A member was removed from a security-enabled Domain Local group

Event 4734 A Security-enabled Domain Local Group was removed

Event 4781 Group Rename (preceduto da 4735 Locale o 4737 Globale o 4755 Universale)

Event 4764 Group Change Type

0 Karma

gcusello
SplunkTrust
SplunkTrust
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @itsmevic,
the search could be something like this:

index=wineventlog (EventCode=4728 OR EventCode=4756)
| table _time Account_name EventCode EventDescription

please check the Account_name field, it could be different (e.g. user)

Ciao.
Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...