Knowledge Management

Windows: Receiving KV store errors

eholz1
Builder

I just installed Splunk ver 7.0, up from ver 6.5
The Splunk server starts, and I can search but I get these errors:

Failed to start KV Store process. See mongod.log and splunkd.log for details. 7/1/2019, 8:51:23 AM  
KV Store changed the status to failed. KVStore process terminated. 7/1/2019, 8:51:12 AM 
KV Store process terminated abnormally (exit code 100, status exited with code 100). See mongod.log and splunkd.log for details. 

I have checked the logs, but see no clear path to fix or eliminate these errors.

Any clues?
Could I copy KV store files from a different Splunk server?

eholz1

0 Karma

eholz1
Builder

Hello All,
I will check the link you provided. Thanks for the replies

0 Karma

jkat54
SplunkTrust
SplunkTrust
0 Karma

woodcock
Esteemed Legend

If this is a lab, blow it away and install fresh.

0 Karma

eholz1
Builder

Not a lab for this case

0 Karma

vishaltaneja070
Motivator

@eholz1

Did you check the mongod,log file which is available in var\log\splunk\mongod.log

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...