Knowledge Management

Tagging Data

JoshuaJJ
Path Finder

Good morning, 

 

 I recently created a tag for a set of hosts. For example, CA for all California hosts. Does this take time to populate or show up within my Data Models?  I am running a search similar to this 

| tstats count FROM datamodel=<data_model>.<root_event> WHERE tag=CA BY _time, host, etc....

 

I have also tried this 

| datamodel  <data_model> <root_event> search 

| search tag=CA

| table _time, host, etc....

Labels (2)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @JoshuaJJ ,

two topics:

is tag a field of your DataModel?

You can check this in your DataModel definition.

if not, you cannot use it or you have to modify your DataModel fields.

if yes, you have to use the <your_datamodel> prefix befor tag in the WHERE condition:

| tstats 
     count 
     FROM datamodel=<data_model>.<root_event> 
     WHERE <data_model>.tag=CA 
     BY _time host

Ciao.

Giuseppe

View solution in original post

0 Karma

JoshuaJJ
Path Finder

Thank you so much for the help. I always forget to add fields to the Data Model 🙂 

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @JoshuaJJ ,

good for you, see next time!

Ciao and happy splunking

Giuseppe

P.S.: Karma Points are appreciated 😉

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @JoshuaJJ ,

two topics:

is tag a field of your DataModel?

You can check this in your DataModel definition.

if not, you cannot use it or you have to modify your DataModel fields.

if yes, you have to use the <your_datamodel> prefix befor tag in the WHERE condition:

| tstats 
     count 
     FROM datamodel=<data_model>.<root_event> 
     WHERE <data_model>.tag=CA 
     BY _time host

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...

Event Series: Mastering AI Tokenomics and Splunk Agent Observability

Beyond the Black Box: Correlating AI Performance and Tokenomics with Splunk Agent Observability   As ...

span_metrics: The OpenTelemetry-Idiomatic Way to See Inside Your Services

You open a trace in Splunk Observability Cloud and everything looks fine. One root span, order-pipeline, with ...