Knowledge Management

Splunk inherit calculated datamodel field don't show in search but show in pivot.

burakatabay
Path Finder

Hi Splunkers,

I try to get some fields on datamodel. And my search is ; 

 

 

| tstats `summariesonly` count from datamodel=Change where nodename=All_Changes.Account_Management.Accounts_Created  by All_Changes.src_user

 

 

 

And src_user field inherit from Account_Management root node.

This search return a results but not showing in web page.

burakatabay_0-1597819468887.png

But I do same thinks on data model pivoting, result is showing.

burakatabay_1-1597820121526.png

 

How ı fix the problem ? 

 

Thank you.

 

 

 

 

 

Labels (2)
0 Karma
1 Solution

harsmarvania57
Ultra Champion

Use below query, src_user field has been extracted under Account_Management

| tstats `summariesonly` count from datamodel=Change where nodename=All_Changes.Account_Management.Accounts_Created  by All_Changes.Account_Management.src_user

View solution in original post

harsmarvania57
Ultra Champion

Use below query, src_user field has been extracted under Account_Management

| tstats `summariesonly` count from datamodel=Change where nodename=All_Changes.Account_Management.Accounts_Created  by All_Changes.Account_Management.src_user
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...