Knowledge Management

SmartStore Eviction Failure

dersonje2
Engager

Hello,

I am experiencing a periodic issue with smartstore where a bucket will try to be evicted then proceeds to fail and does that cycle thousands of times. The indexer IO is fine, the bucket is warm, we have enough cache sizing, and I have not been able to correlate any cache logs with when these failures begin on multiple indexer nodes in the cluster (~33% of indexers).

2 questions:
* What is an urgent mode eviction?
* What can cause warm buckets to be unable to be evicted when they rolled to warm ~a full day earlier?

Labels (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

A warm bucket will not be evicted if it is too new on the premise that new data is more likely to be searched than old data.  "new" is defined by hotlist_recency_secs  and hotlist_bloom_filter_recency_hours  in indexes.conf.

Urgent mode eviction comes into play when there are not enough files eligible for normal eviction.  In urgent mode, the hotlist_recency_secs and hotlist_bloom_filter_recency_hours settings are ignored.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...