Knowledge Management

How to get the mapping relationship between data models and indexes?

Iris_Pi
Path Finder

Hello Guys,

I wonder if there's any query that can list the mapping information between the existing  data models and indexes? I would like to use these info to set index constrains for data models to speed up searching.

Thanks & Regards,
Iris

Labels (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Use this query to find out which indexes are used by a data model.

| tstats count from datamodel=foo by index
---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...