Knowledge Management

Editing macro is giving a 404 error


When I tried to edit a macro in Settings\all Settings it is giving a 404

alt text

It seems the generated URL usees ../data/.. it should be ../admin/ , is there any way to fix the render url to use the /admin/ instead of /data/?


Tags (2)


2 years in and I am facing this issue now also, however going to settings -> advanced search -> search no longer works either.

Chaning /data/ to /admin/ does the trick however

0 Karma


I have faced the issue on many occasions. Earlier I used to bang my head facing this issue as it never allows to edit the macro seamlessly. This seems like an issue with App Permissions. But, now I never jump to 'All Configurations' windows and search the Macro there, instead I visit Advanced Search >> Macros.

What I assume, when we jump to Advanced Setting from the Current app, it sets the context of the app which is selected and if the macro has permissions restricted to a particular app, Splunk will not let you edit the configuration.

So, I always prefer, Advanced Search >> Macros way.


Doesn't fix the bug, but accessing via settings -> advanced search -> search macros works for editing macros.

0 Karma
Get Updates on the Splunk Community!

Enterprise Security Content Update (ESCU) | New Releases

In the last month, the Splunk Threat Research Team (STRT) has had 2 releases of new security content via the ...

Announcing the 1st Round Champion’s Tribute Winners of the Great Resilience Quest

We are happy to announce the 20 lucky questers who are selected to be the first round of Champion's Tribute ...

We’ve Got Education Validation!

Are you feeling it? All the career-boosting benefits of up-skilling with Splunk? It’s not just a feeling, it's ...