Installation

Why am I unable to connect to license master?

tokio13
Path Finder

Hello,

I'm experiencing some issues with my Cluster Master. The instance for the CM had to be replaced and Splunk was reinstalled on  new instance. Configuration was deployed exactly how it was before (CM was working fine) moving to this new instance with the Cluster Master.

The issue is the following:

Failed to contact license master: reason='Unable to connect to license master=https://xxxxxxxx-mc1:8089 Error resolving: Name or service not known'

Thanks to anyone that could lend a helping hand

Labels (1)
0 Karma
1 Solution

isoutamo
SplunkTrust
SplunkTrust

Hi

this means that your host cannot resolve Your LM hostname. It could be that your node has different domain name or dns it not working. The correct way is to fix your node's DNS to work. Workaround can be to add your LM's IP - Name combination to your local hosts file on this node.

r. Ismo

View solution in original post

tokio13
Path Finder

Thank you all for stepping in for helping me. I'm actively working on applying your recommendations. I'll post back the result once I'm done and hopefully have a working environment, hoping that it will help someone else as well in the future.

VatsalJagani
SplunkTrust
SplunkTrust

Please update the pass4Symm key in server.conf or from clustering UI on CM. Because if you have copied the configuration over, new Splunk might not be able to decrypt the credentials. 

Also, make sure you validate all IP addresses information and specifically check the server.conf configuration.

tokio13
Path Finder

Thanks! 

0 Karma

SinghK
Builder

Change it to IPaddress of your LM and it will work.

0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

never ever use IP address on splunk configurations! That works only if you have static environment where you never need to change anything (like update node to new, switch roles, add new nodes etc), in all other cases it will generate new issues later on. 
It’s much better to fix the real issue now than later. 
r. Ismo

PickleRick
SplunkTrust
SplunkTrust

Yep. Also there can be issues with issuing certificates for IP-s instead of hostnames. It can be done, but some CA's have problems with it and some CA operators have even bigger issues with that practice 😉

SinghK
Builder

Ok @isoutamo , thanks

isoutamo
SplunkTrust
SplunkTrust

Hi

this means that your host cannot resolve Your LM hostname. It could be that your node has different domain name or dns it not working. The correct way is to fix your node's DNS to work. Workaround can be to add your LM's IP - Name combination to your local hosts file on this node.

r. Ismo

tokio13
Path Finder

Thanks everyone!

Your input helped with solving my issue. I added the missing hosts in /etc/hosts and hashed the pass4SymmKey in [general] stanza to generate a new one at restart. 

0 Karma
Get Updates on the Splunk Community!

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...

Get More Out of Your Security Practice With a SIEM

Get More Out of Your Security Practice With a SIEMWednesday, July 31, 2024  |  11AM PT / 2PM ETREGISTER ...