Installation

Why Do I Get a 404 Error When I Install and Launch Splunk For the First Time Locally On My Windows PC?

ScottMacD
New Member

I am getting prepared to begin using Splunk on a work project, and am trying to do some training before hand. So I installed Splunk, ran it, and it opened in Edge with a 404 error in localhost:8000. It is saying Edge can't find this page. What can I do to get this working?

Tags (1)
0 Karma

woodcock
Esteemed Legend

Avoid using Splunk on Windows, it is a path fraught with downsides:
https://answers.splunk.com/answers/516059/what-are-the-pain-points-with-deploying-your-splun.html

0 Karma

skoelpin
SplunkTrust
SplunkTrust

Open up your Services and verify Splunk is running. Try using another browser

0 Karma

ScottMacD
New Member

I switched the default browser in settings to IE, instead of Edge. That didn't work, but it didn't 404. I then put localhost:8001 when I did that, and it asked me to login.

0 Karma

skoelpin
SplunkTrust
SplunkTrust

It's hosted by the server so browser doesn't matter, but I try to stay away from anything Windows related when possible which is why I mentioned using a different browser.

It looks like you may have changed the default port when installing. If its working now, can you accept the answer to close it out?

0 Karma

ScottMacD
New Member

OK, so here is the thing. I'm running this on Windows so I click start>all programs>splunk enterprise and it launches in edge automatically. And it doesn't give me any options to change browser it just throws that error automatically. How do I go about making those sort of changes?

0 Karma

ScottMacD
New Member

OK, I didn't know that. I tried another browser same thing. I checked services and it shows splunkd is running, and splunkweb is stopped. I tried to start it, and it threw an error.

0 Karma

skoelpin
SplunkTrust
SplunkTrust

Did you enable SSL when installing? If so then use https://localhost:8000

0 Karma

ScottMacD
New Member

It didn't give me an option to, I just installed using the defaults.

0 Karma

skoelpin
SplunkTrust
SplunkTrust

You should look at the Splunk logs to see what the issue is

They are located under $SPLUNK_HOME\var\log\splunk\splunkd.log

0 Karma

DalJeanis
SplunkTrust
SplunkTrust

1) follow instructions here to start splunk

http://docs.splunk.com/Documentation/Splunk/6.6.1/Installation/StartSplunkforthefirsttime

then

2) Open a prowser and point to http://localhost:8000

0 Karma

ScottMacD
New Member

OK, I tried to launch from command prompt like instructions here. Apparently it was trying to set it to port 8001, which was already bound. I tried to set it to port 8000 same thing. What should I do?

0 Karma

ScottMacD
New Member

There is no icon except Splunk enterprise in my Windows Instance, no edit configuration option or anything like that. So if I click it, it just launches to Edge.

0 Karma

skoelpin
SplunkTrust
SplunkTrust

Have you checked your Services to verify its running?

If it's running, which it should be since Windows starts it at boot. You should simply be able to open a different browser and type in localhost:8000

0 Karma
Get Updates on the Splunk Community!

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...

Ready, Set, SOAR: How Utility Apps Can Up Level Your Playbooks!

 WATCH NOW Powering your capabilities has never been so easy with ready-made Splunk® SOAR Utility Apps. Parse ...

DevSecOps: Why You Should Care and How To Get Started

 WATCH NOW In this Tech Talk we will talk about what people mean by DevSecOps and deep dive into the different ...