Installation

Web server not starting

Herman
Explorer

First time installing Splunk. I tried to reinstall the Splunk and web server is still not starting. I also need to change the mgmt port number as the previous one is still using the default port and I have no idea how to disable the previous session. 

 

./splunk start

 

Splunk> Winning the War on Error

 

Checking prerequisites...

Checking mgmt port [8111]: open

Checking conf files for problems...

Done

Checking default conf files for edits...

Validating installed files against hashes from '/Applications/splunkforwarder/splunkforwarder-8.1.2-545206cc9f70-darwin-64-manifest'

All installed files intact.

Done

All preliminary checks passed.

 

Starting splunk server daemon (splunkd)...  

Done

 

bin % ./splunk cmd btool web list --debug | grep startwebserver

/Applications/splunkforwarder/etc/apps/SplunkUniversalForwarder/default/web.conf startwebserver = 0

Labels (1)
0 Karma

Vardhan
Path Finder

Try the below link and download the Splunk enterprise full version and install it. And Remove the existing package.

https://www.splunk.com/en_us/download/splunk-enterprise.html#tabs/macos

0 Karma

Vardhan
Path Finder

Hi @Herman ,

 

It looks like your not installing the Splunk enterprise version your installing the Splunk universal forwarder agent.

Are you trying to install the Splunk or Splunk agent?

Herman
Explorer

Really? But I remember I downloaded Splunk Enterprise for macOS. I downloaded both .tgz and .dmg hoping one of them would start the webserver, but neither of them work. It justs doesn't have the web server and app server like other people do. I have been trying to figure out why. 

0 Karma